<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
<title>Trump Arrogantly Declared His Inauguration a National Holiday - Just Like Someone Else | United Liberty | Free Market - Individual Liberty - Limited Government</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<meta name="copyright" content="(c) 2005-2013 United Liberty"/>
<meta name="DC.Title" content="Trump Arrogantly Declared His Inauguration a National Holiday - Just Like Someone Else"/>
<meta name="description" content="- The internet outrage machine kicked into high gear this week when President Trump declared his inauguration day a National Day of Patriotic Devotion. The order itself is fairly inoccuous. There are no greater people than the American citizenry, and as"/>
<meta name="keywords" content="Politics,News,Blog,Current,Alternative,Libertarian,Freedom,Election,Nonpartisan,Ron Paul"/>
<meta name="robots" content="index,follow"/>
<script type="text/javascript" src="http://w.sharethis.com/widget/?tabs=web%2Cpost%2Cemail&amp;services=reddit%2Cdigg%2Cfacebook%2Cdelicious%2Cpropeller%2Cmixx&amp;charset=utf-8&amp;style=default&amp;publisher=d4a10265-492e-4646-82f0-bb513c7ca25f"></script>
<link rel="shortcut icon" href="/sites/default/themes/unitedliberty/favicon.ico" type="image/x-icon"/>
<style type="text/css" media="all">@import "/modules/aggregator/aggregator.css";</style>
<style type="text/css" media="all">@import "/modules/book/book.css";</style>
<style type="text/css" media="all">@import "/modules/node/node.css";</style>
<style type="text/css" media="all">@import "/modules/system/defaults.css";</style>
<style type="text/css" media="all">@import "/modules/system/system.css";</style>
<style type="text/css" media="all">@import "/modules/user/user.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/cck/content.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/extlink/extlink.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/livesearch/livesearch.css";</style>
<style type="text/css" media="all">@import "/modules/search/search.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/tagadelic/tagadelic.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/weblinks/weblinks.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/cck/fieldgroup.css";</style>
<style type="text/css" media="all">@import "/sites/all/modules/devel-5.x-0.3/devel/devel.css";</style>
<style type="text/css" media="all">@import "/sites/default/themes/unitedliberty/style.css";</style>
<script type="text/javascript" src="/files/js/6964f34469d9892283bf9aa4c814d197.js"></script>
<script type="text/javascript">Drupal.extend({ settings: { "extlink": { "extTarget": "_blank", "extClass": 0, "extSubdomains": 0, "mailtoClass": "mailto" }, "liveSearch": { "targetSearchBox": "block", "compactSearchBox": 1, "delayDuration": "500", "queryURL": "/livesearch/node", "minimumWordSize": "3", "useCustomElement": false, "customElementId": "", "hideSnippets": 1, "showItemInfo": 1, "scrollToResults": 0, "searchAllowed": true } } });</script>
</head>
<body class="node node-19742">
<div id="page">
<div id="header">
<h1><a href="/" title="United Liberty Home"><span><img src="/sites/default/themes/unitedliberty/images/unitedliberty.gif" alt="United Liberty"/> United Liberty</span></a></h1>
<div id="search">
<form action="/search/node" method="get">
<div><input type="text" value="Search" name="keys" id="top-search" class="autoreset"/></div>
</form>
</div>
</div>
<div id="top-bar">
<ul id="top-stuff">
<li><a href="/rss.xml" title="Subscribe to our RSS feed"><img src="/sites/default/themes/unitedliberty/images/feed.png" alt="Feed"/></a></li>
<li><a href="/login">Log in</a></li>
<li class="last"><a href="/user/register">Create Account</a></li>
</ul>
<div id="nav">
<ul><li class="menu-1-1-2 first"><a href="/"><span>Home</span></a></li>
<li class="menu-1-2-2"><a href="/videos"><span>Media Center</span></a></li>
<li class="menu-1-3-2 last"><a href="http://www.unitedliberty.org/join-our-mail-list"><span>Subscribe to Today in Liberty</span></a></li>
</ul>
</div>
</div>
<div id="main-column">
<div id="main-column-inner">
<h2 class="page-title"><span>Trump Arrogantly Declared His Inauguration a National Holiday - Just Like Someone Else</span></h2> <div id="node-19742" class="post sticky clear-block">
<div class="post-details">
<span class="submitted">Tue, 01/24/2017 - 9:15am | posted by <a href="/users/mdesormeaux" title="View user profile.">Matthew DesOrmeaux</a></span>
</div>
<div class="content">
<iframe src='http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.unitedliberty.org%2Farticles%2F19742-trump-arrogantly-declared-his-inauguration-a-national-holiday&amp;layout=standard&amp;show_faces=true&amp;width=450&amp;action=like&amp;colorscheme=light' scrolling='no' frameborder='0' allowTransparency='true' style='border:none; overflow:hidden; width:450px; height:25px'></iframe><p><img src="/files/images/Mural_outside_Songdowon_Hotel%2C_Wonsan.jpg" alt="-" width="560"/></p> <p>The internet outrage machine kicked into high gear this week when President Trump declared his inauguration day a <a href="https://www.washingtonpost.com/news/post-politics/wp/2017/01/23/trump-names-his-inauguration-day-a-national-day-of-patriotic-devotion/?utm_term=.dad9a04db9ab" target="_blank">National Day of Patriotic Devotion</a>. <a href="https://s3.amazonaws.com/public-inspection.federalregister.gov/2017-01798.pdf" target="_blank">The order</a> itself is fairly inoccuous.</p> <blockquote><p>There are no greater people than the American citizenry, and as long as we believe in ourselves, and our country, there is nothing we cannot accomplish.</p></blockquote> <p>The level of arrogance required to declare your own inauguration a national holiday, though, is astounding. Unsurprisingly, it reminded many of third world despots.</p> <blockquote class="twitter-tweet"><p dir="ltr" lang="en">Orange pelted poodle Donald Trump, in pitiable attempt to ape Juche Idea of General Kim Il-Sung, declares National Day of Patriotic Devotion <a href="https://t.co/jQqzQU71iv">pic.twitter.com/jQqzQU71iv</a></p> <p>— DPRK News Service (@DPRK_News) <a href="https://twitter.com/DPRK_News/status/823641527750627332">January 23, 2017</a></p></blockquote> <p></p> <p>And it&#8217;s not far off. Banana republic leaders do indeed tend to engage in this kind of megalomania. Castro declared his revolution a <a href="https://en.wikipedia.org/wiki/Triumph_of_the_Revolution" target="_blank">national holiday in Cuba</a>. His successor in Venezuela honored <a href="http://www.telegraph.co.uk/news/worldnews/southamerica/venezuela/10429409/Venezuela-new-national-holiday-celebrating-Hugo-Chavez-clashes-with-elections.html" target="_blank">Hugo Chavez&#8217;s death with a national holiday</a>. The <a href="https://en.wikipedia.org/wiki/Day_of_the_Sun" target="_blank">Day of the Sun</a> in North Korea commemmorates the birth of its first Communist dictator, Kim Il-sung.</p> <p>One other recent prominent world leader declared his taking office a national holiday. January 20, 2009 was declared a <a href="https://webcache.googleusercontent.com/search?q=cache%3ABd5b4cwqmmkJ%3Ahttps%3A%2F%2Fwww.whitehouse.gov%2Fthe-press-office%2Fnational-day-renewal-and-reconciliation-2009%20&amp;cd=1&amp;hl=en&amp;ct=clnk&amp;gl=us" target="_blank">National Day of Renewal and Reconciliation</a>. That date should look familiar. It was President Obama&#8217;s inauguration.</p> <blockquote class="twitter-tweet"><p dir="ltr" lang="en">It’s gross. But not unique: Obama did the same. We need a culture change in the presidency. <a href="https://t.co/HpQDJnNuwD">https://t.co/HpQDJnNuwD</a> <a href="https://t.co/Or3HLPkRSo">https://t.co/Or3HLPkRSo</a></p> <p>— Charles C. W. Cooke (@charlescwcooke) <a href="https://twitter.com/charlescwcooke/status/823670913388441603">January 23, 2017</a></p></blockquote> <p>The usual tribal cliches will reflexively pour out here. &#8220;But but but! Trump bad! Obama good!&#8221; From a certain perspective.</p> <p>From a more objective perspective, though, both declarations were stunning displays of arrogance. Obama believed his election would heal partisan and racial divides, so he declared a holiday to jump start the process. Spoiler alert: It didn&#8217;t. Trump believes his election will make the nation more patriotic and unified, so he made it an official proclamation. Again, it won&#8217;t.</p> <p>If you think one man&#8217;s election deserved official national celebration but the other didn&#8217;t, before either one had actually done anything in office, you&#8217;re only declaring your own tribal allegiance, not an objective appraisal.</p> <p>Some elections deserve celebration, of course, like that of the first black president of a nation built in part on chattel slavery and that continues to struggle with racial justice, or our eventual first female president. But it should be celebrated by the people or their representatives, not the man himself (or woman herself) by national decree.</p> <p>In a constitutional republic of free citizens, no one&#8217;s election automatically deserves a national holiday. Winning a campaign isn&#8217;t a national accomplishment, it&#8217;s a procedural coin flip. Do something first, then the people will decide if you deserve commemoration.</p> </div>
<div class="divider"></div><div class="block" id="">
<div class="content"></div>
</div>
<div class="post-meta">
<ul class="links inline"><li class="comment_forbidden first"><span><a href="/user/login?destination=node/19742%2523comment-form">Login</a> or <a href="/user/register?destination=node/19742%2523comment-form">register</a> to post comments</span></li>
<li class="statistics_counter"><span>2077 reads</span></li>
<li class="share_1_19742 last"><span><script language="javascript" type="text/javascript">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</script></span></li>
</ul> </div>
<div style="clear:both;"></div>
</div>
<div class="divider"></div> </div>
</div>
<div id="second-column">
<div class="block" id="block-22">
<div class="content"><p><a href="/join-our-mail-list"><img src="/files/images/UL_JoinMailingListJustGraphic2_0.jpg" title="Join Mail List" height="62" width="364"></p></div>
</div>
<div class="block" id="featured-posts">
<h3 class="title"><span>Featured posts</span></h3>
<div class="content">
<ul class="post-list">
<li>
<div class="picture"><a href="/users/mdesormeaux" title="View user profile."><img src="http://www.unitedliberty.org/files/avatars/picture-26517.jpg" alt="authoridad&#039;s picture" title="authoridad&#039;s picture"/></a></div> <div class="content">
<h4><a href="/articles/19745-pence-becomes-first-ever-vp-to-address-march-for-life-and-it-was-worth-the-wait">Pence Becomes First Ever VP to Address March for Life - And It Was Worth the Wait</a></h4>
by <a href="/users/mdesormeaux" title="View user profile.">Matthew DesOrmeaux</a> </div>
<div style="clear:both;"></div>
</li>
<li>
<div class="picture"><a href="/users/mdesormeaux" title="View user profile."><img src="http://www.unitedliberty.org/files/avatars/picture-26517.jpg" alt="authoridad&#039;s picture" title="authoridad&#039;s picture"/></a></div> <div class="content">
<h4><a href="/articles/19742-trump-arrogantly-declared-his-inauguration-a-national-holiday">Trump Arrogantly Declared His Inauguration a National Holiday - Just Like Someone Else</a></h4>
by <a href="/users/mdesormeaux" title="View user profile.">Matthew DesOrmeaux</a> </div>
<div style="clear:both;"></div>
</li>
<li>
<div class="picture"><a href="/users/mdesormeaux" title="View user profile."><img src="http://www.unitedliberty.org/files/avatars/picture-26517.jpg" alt="authoridad&#039;s picture" title="authoridad&#039;s picture"/></a></div> <div class="content">
<h4><a href="/articles/19739-obamas-legacy-drug-warrior-in-chief">Obama&#8217;s Legacy: Drug Warrior-in-Chief</a></h4>
by <a href="/users/mdesormeaux" title="View user profile.">Matthew DesOrmeaux</a> </div>
<div style="clear:both;"></div>
</li>
<li>
<div class="picture"><a href="/users/mdesormeaux" title="View user profile."><img src="http://www.unitedliberty.org/files/avatars/picture-26517.jpg" alt="authoridad&#039;s picture" title="authoridad&#039;s picture"/></a></div> <div class="content">
<h4><a href="/articles/19738-this-is-not-about-meryl-streep">This is not about Meryl Streep</a></h4>
by <a href="/users/mdesormeaux" title="View user profile.">Matthew DesOrmeaux</a> </div>
<div style="clear:both;"></div>
</li>
</ul>
</div>
</div>
<div class="block" id="social-networks">
<div class="content"> <ul>
<li class="facebook"><a href="http://www.facebook.com/pages/United-Liberty/112228374951"><span>Facebook</span></a></li>
<li class="twitter"><a href="http://twitter.com/unitedliberty"><span>Twitter</span></a></li>
</ul></div>
</div>
<div class="block" id="block-15">
<div class="content"><p><a class="twitter-timeline" width="400" height="500" href="https://twitter.com/unitedliberty/united-liberty-writers" data-widget-id="368035929631367169">Tweets from @unitedliberty/united-liberty-writers</a></p>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
</div>
<div class="block" id="tagadelic-11">
<h3 class="title"><span>tags in Tags</span></h3>
<div class="content"><a href="/tags/barack-obama-0" class="tagadelic level4" rel="tag">Barack Obama</a>
<a href="/tags/economy" class="tagadelic level1" rel="tag">Economy</a>
<a href="/tags/mitt-romney" class="tagadelic level2" rel="tag">Mitt Romney</a>
<a href="/tags/obama-administration" class="tagadelic level1" rel="tag">Obama administration</a>
<a href="/tags/obamacare" class="tagadelic level3" rel="tag">ObamaCare</a>
<a href="/tags/rand-paul" class="tagadelic level1" rel="tag">Rand Paul</a>
<a href="/tags/republican-party" class="tagadelic level1" rel="tag">Republican Party</a>
<a href="/tags/republicans" class="tagadelic level2" rel="tag">Republicans</a>
<a href="/tags/ron-paul" class="tagadelic level1" rel="tag">Ron Paul</a>
<a href="/tags/spending" class="tagadelic level1" rel="tag">Spending</a>
<a href="/tags/taxes" class="tagadelic level1" rel="tag">Taxes</a>
<a href="/tags/tea-party" class="tagadelic level1" rel="tag">Tea Party</a>
<div class='more-link'><a href="/tagadelic/chunk/11">more tags</a></div></div>
</div>
<div class="block" id="sidebar-links">
<div class="content">
<div class="subsection">
<div class="archives">
<h3><span>Archives</span></h3><ul>
<li><a href="/archives/2017/1">January 2017</a></li>
<li><a href="/archives/2016/12">December 2016</a></li>
<li><a href="/archives/2016/11">November 2016</a></li>
<li><a href="/archives/2016/10">October 2016</a></li>
<li><a href="/archives/2016/9">September 2016</a></li>
<li><a href="/archives/2016/8">August 2016</a></li>
<li><a href="/archives/2016/7">July 2016</a></li>
<li><a href="/archives/2016/6">June 2016</a></li>
</ul>
</div>
</div>
<div class="subsection">
<div class="blogs-sites">
<div class="block" id="weblink-214">
<h3 class="title"><span>Blogs &amp; Sites</span></h3>
<div class="content"><div class="item-list"><ul class="weblinks"><li class="weblinks weblinks-item weblinks-link-4713"><div class="weblinks-link"><a href="http://www.spectator.org" target="_blank">American Spectator</a></div></li><li class="weblinks weblinks-item weblinks-link-4368"><div class="weblinks-link"><a href="http://cafehayek.com/" target="_blank">Cafe Hayek</a></div></li><li class="weblinks weblinks-item weblinks-link-3192"><div class="weblinks-link"><a href="http://www.cato.org/blog" target="_blank">Cato @ Liberty</a></div></li><li class="weblinks weblinks-item weblinks-link-12205"><div class="weblinks-link"><a href="http://driveinnovation.org/_blog/Blog" target="_blank">CLIP Blog</a></div></li><li class="weblinks weblinks-item weblinks-link-6310"><div class="weblinks-link"><a href="http://daviddfriedman.blogspot.com/" target="_blank">David Friedman</a></div></li><li class="weblinks weblinks-item weblinks-link-6316"><div class="weblinks-link"><a href="http://www.divisionoflabour.com/" target="_blank">Division of Labour</a></div></li><li class="weblinks weblinks-item weblinks-link-6305"><div class="weblinks-link"><a href="http://econlog.econlib.org/" target="_blank">EconLog</a></div></li><li class="weblinks weblinks-item weblinks-link-6318"><div class="weblinks-link"><a href="http://www.fivethirtyeight.com/" target="_blank">FiveThirtyEight</a></div></li><li class="weblinks weblinks-item weblinks-link-6309"><div class="weblinks-link"><a href="http://gregmankiw.blogspot.com/" target="_blank">Greg Mankiw</a></div></li><li class="weblinks weblinks-item weblinks-link-3753"><div class="weblinks-link"><a href="http://hnn.us/blogs/4.html" target="_blank">Liberty & Power</a></div></li><li class="weblinks weblinks-item weblinks-link-6892"><div class="weblinks-link"><a href="http://dailycaller.com/mattlewis/" target="_blank">Matt Lewis & The News</a></div></li><li class="weblinks weblinks-item weblinks-link-3191"><div class="weblinks-link"><a href="http://www.thelibertypapers.org" target="_blank">The Liberty Papers</a></div></li><li class="weblinks weblinks-item weblinks-link-6307"><div class="weblinks-link"><a href="http://thirdbasepolitics.blogspot.com/" target="_blank">Third Base Politics</a></div></li><li class="weblinks weblinks-item weblinks-link-3227"><div class="weblinks-link"><a href="http://www.washingtonwatch.com" target="_blank">Washington Watch</a></div></li><li class="weblinks weblinks-item weblinks-link-6317"><div class="weblinks-link"><a href="http://www.willwilkinson.net/flybottle/" target="_blank">Will Wilkinson</a></div></li></ul></div></div>
</div>
</div>
<div class="candidates">
<div class="block" id="">
<div class="content"></div>
</div>
</div>
<div class="organizations">
<div class="block" id="weblink-493">
<h3 class="title"><span>Organizations</span></h3>
<div class="content"><div class="item-list"><ul class="weblinks"><li class="weblinks weblinks-item weblinks-link-774"><div class="weblinks-link"><a href="http://campaignforliberty.com/" target="_blank">Campaign for Liberty</a></div></li><li class="weblinks weblinks-item weblinks-link-3882"><div class="weblinks-link"><a href="http://www.cato.org" target="_blank">Cato Institute</a></div></li><li class="weblinks weblinks-item weblinks-link-12206"><div class="weblinks-link"><a href="http://driveinnovation.org/" target="_blank">Communications Liberty and Innovation Project</a></div></li><li class="weblinks weblinks-item weblinks-link-1465"><div class="weblinks-link"><a href="http://www.downsizedc.org/" target="_blank">Downsize DC</a></div></li><li class="weblinks weblinks-item weblinks-link-3873"><div class="weblinks-link"><a href="http://www.fee.org/" target="_blank">Foundation for Economic Education</a></div></li><li class="weblinks weblinks-item weblinks-link-775"><div class="weblinks-link"><a href="http://www.freedomadvocates.org/" target="_blank">Freedom Advocates</a></div></li><li class="weblinks weblinks-item weblinks-link-2269"><div class="weblinks-link"><a href="http://www.freedomworks.org" target="_blank">FreedomWorks</a></div></li><li class="weblinks weblinks-item weblinks-link-5956"><div class="weblinks-link"><a href="http://pac.freedomworks.org" target="_blank">FreedomWorks PAC</a></div></li><li class="weblinks weblinks-item weblinks-link-5510"><div class="weblinks-link"><a href="http://www.taxfoundation.org" target="_blank">Tax Foundation</a></div></li><li class="weblinks weblinks-item weblinks-link-5954"><div class="weblinks-link"><a href="http://yaliberty.com" target="_blank">Young American's for Liberty</a></div></li></ul></div></div>
</div>
</div>
</div>
<div style="clear: both"></div></div>
</div>
</div>
<div style="clear:both;"></div>
<hr/>
<div id="sitelinks">
<div class="block" id="popular-posts">
<h3 class="title"><span>Popular posts</span></h3>
<div class="content">
<ul>
<li><a href="/articles/19742-trump-arrogantly-declared-his-inauguration-a-national-holiday">Trump Arrogantly Declared His Inauguration a National Holiday - Just Like Someone Else
<br/><em>Tue, 01/24/2017 - 9:15am / 2077 views</em></a></li>
<li><a href="/articles/19745-pence-becomes-first-ever-vp-to-address-march-for-life-and-it-was-worth-the-wait">Pence Becomes First Ever VP to Address March for Life - And It Was Worth the Wait
<br/><em>Fri, 01/27/2017 - 2:09pm / 69 views</em></a></li>
</ul>
<div class="more">
<a href="/popular">more &raquo;</a>
</div>
</div>
</div>
<div style="clear:both;"></div>
</div>
<div id="footer">
<ul><li class="menu-1-1-2 first"><a href="/"><span>Home</span></a></li>
<li class="menu-1-2-2"><a href="/videos"><span>Media Center</span></a></li>
<li class="menu-1-3-2 last"><a href="http://www.unitedliberty.org/join-our-mail-list"><span>Subscribe to Today in Liberty</span></a></li>
</ul>
<div class="copyright"><a href="/privacy-policy" style="color:white;border-bottom:1px dotted white;">Privacy Policy</a> |
&copy; 2005-2009 UnitedLiberty.org. All rights reserved.
</div>
<div style="clear:both;"></div>
</div>
<div id="disclaimer">
The views and opinions expressed by individual authors are not necessarily those of other authors, advertisers, developers or editors at United Liberty.
</div>
</div>
<script type="text/javascript" src="/sites/all/modules/google_analytics/googleanalytics.js"></script>
<script type="text/javascript">Drupal.extend({ settings: { "googleanalytics": { "trackOutgoing": 1, "trackMailto": 1, "trackDownload": 1, "trackDownloadExtensions": "7z|aac|avi|csv|doc|exe|flv|gif|gz|jpe?g|js|mp(3|4|e?g)|mov|pdf|phps|png|ppt|rar|sit|tar|torrent|txt|wma|wmv|xls|xml|zip", "LegacyVersion": 0 } } });</script>
<script type="text/javascript">var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script>
<script type="text/javascript">var pageTracker = _gat._getTracker("UA-4343617-1");pageTracker._initData();pageTracker._trackPageview();</script>
</body>
</html>
